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Introduction                                           

This document is one of several aids that are provided to help with the installation and use
WinIATE.  It is assumed that the reader is familiar with fundamentals of DOS and Windows.  The
reader should also have some understanding of airline communication principles, particularly
interchange/terminal addressing and display/printer options.

As a first step, an overview of the entire WinIATE system is presented, followed by the
instructions for installing and using the WinIATE Terminal software.  

__________________________________________________________________________
Overview                                                                       

The WinIATE system consists of communications software and hardware that provide
connectivity to the Host, and terminal emulation software that provides airline terminal
functionality.  

WinIATE works in conjunction with the InnoSys Gateway software and hardware installed on a
workstation in a Local Area Network (LAN) or Wide Area Network (WAN) environment.  The
Gateway is normally connected to the Host modem via a standard RS-232 cable.    

A typical WinIATE system is shown below: 

Diagram of typical LAN-based WinIATE system
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______________________________________________________________________________
Requirements

The Terminal runs on any PC running Windows version 3.1, 3.11, or higher; Windows for
Workgroups; Windows NT, and Windows 95.  The terminal software will run in less than 1MB of
RAM.  If other applications will be running concurrently on the PC, additional RAM is required.  

The WinIATE software can be configured in a number of different way.  The preferred method
for changing configuration parameters is to use the configuration dialog boxes presented by the
WinIATE terminal software.  However, a text editor (for example, the EDIT program) or word
processor that can read and write ASCII files can be used if the user wishes to directly modify
WinIATE configuration files.  Certain configuration parameters can only be modified in this
manner.
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Preparation

Before installing the Terminal, the workstation PC must be set up and an InnoSys IATE Gateway
must be installed.  The user must also obtain the Object Name that is defined for this terminal in
the Gateway configuration.

______________________________________________________________________________
The LAN/WAN

The Terminal communicates with the Gateway over a Local Area Network (LAN), a Wide Area
Network (WAN), or the Internet, using TCP/IP.  Ensure that TCP/IP is installed on the
workstation  where WinIATE will be installed and that the network is up and running before
trying to install or start WinIATE.

The workstation where WinIATE will be installed should have a utility (such as “ping”) which
lets a user check the workstation’s connection to other PC’s on the network.  To check the
connection to the Gateway machine, use ping with that machine’s IP address.  For example,
suppose that the IP address of the Gateway machine is 192.0.1.18.  Enter:

ping 192.0.1.18
and press the Enter key.  The utility should report answerbacks from the Gateway machine.  If no
responses appear, stop the ping utility and try it again once more.  If there is still no response,
check the IP addresses and any other configuration parameters on both sides of the connection.

______________________________________________________________________________
Setting Up the PC

The procedure for setting up the workstation is explained in the PC owner’s manual.  

______________________________________________________________________________
IATE Object Names

Configuration of WinIATE requires an IATE CRT (or CRT API) Object Name and optionally a
Printer Object Name.  Before beginning the installation process, be sure to determine the CRT
Object Name(s) that were created for this terminal as part of the Gateway configuration process.
To use any available terminal that has been set up as a “CRT API” (for dynamic linking), use the
“*” (star) character as the Object Name.  To have the terminal use any available TA from a
“group” of TAs which has been defined at the Gateway, use the name of the group as the Object
Name.
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Installing the Terminal               
Installation of WinIATE involves the following four steps, described in detail below.  

• Verify that the gateway PC can be “pinged”
• Install the Terminal software
• Install the fonts
• Configure the Terminal 

______________________________________________________________________________
Installing the Terminal Software                                                                

To install the WinIATE terminal emulator software, use the following procedure: 

1) Power on the PC.

2) Try to “Ping” the gateway PC.  If this is not successful, do not proceed until the
gateway can be successfully pinged.

The easiest way to install the software is from the standard distribution media.  To install from the
distribution media:

3a1) If the software was delivered on disks, insert the first distribution disk in the “a:” drive.
Select Run from the “Start” menu and enter a:setup.exe.  Follow the prompts through
the installation process, or,

3a1) If the software was delivered via email, create a temporary directory and “unzip” the
email attachment(s) into the temporary directory.  Select Run from the “Start” menu and
enter setup.exe from the temporary directory.  Follow the prompts through the
installation process.

Alternatively, the WinIATE software can be installed manually by using the following procedure:

3b)Insert the distribution disk into a floppy drive.

4b)Create a directory named “WINIATE”.  Copy the WINIATE.EXE, IATEHELP.HLP,
TERMKEYS, and WINIATE.BMP into the WinIATE directory.

5b)Copy the IATEDLL.DLL file to the \WINDOWS Directory if running Windows 3.1,
WFW, or 95; or to the \WINNT40 Directory if running NT.

6b)The workstation’s TCP/IP software should include a directory that contains files named
“HOSTS” and “SERVICES”.  Under Windows for Workgroups  Windows 95 these files
are in the \WINDOWS directory.  Under Windows NT these files are in the
\WINNT40\SYSTEM32\DRIVERS\ETC directory.   If running PC/NFS, these files should
be in the \NFS directory.   If running Trumpet, these files should be in the \TRUMPET
directory.  Add a line to the “HOSTS” file specifying the name and IP address of the
Gateway PC.  (Create the file if it does not already exist.)  For example, if the gateway
machine’s address is 192.0.1.18 and its name is “innogw”, the correct line would be:

192.0.1.18   innogw
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Note: adding a line to the hosts file is not necessary if a Domain Name Server (“DNS”) is
being used on the network to resolve host names.

7b)In the same directory where the HOSTS file resides, add a line to the SERVICES file that
specifies the service name and port number for the connection to the Gateway.  (Create
this file if it does not already exist.)  The most commonly used name and number for an
InnoSys IATE gateway are “ialcserver” and 1413.  The correct format for this line is:

ialcserver 1413/tcp

______________________________________________________________________________
Installing Fonts                                                                    

It should not be necessary to install the fonts as a separate step if the terminal software was
installed using “Setup”.

For workstations running Windows 3.1 or WFW, install the WinIATE fonts according to the
procedure described in Appendix B of this manual.

For workstations running Windows 95 or NT, drag the fonts to the fonts folder.  If the IATE and
ALC fonts do not appear when “Fonts” is selected from the “Text” pull-down menu in the
terminal application, open the fonts folder and double-click on either the IATE or ALC font.
Then close the font and the folder.  The fonts should now be available to the terminal application.

The IATE font is used for SABRE.  The ALC font is used for all other hosts.

______________________________________________________________________________
Configuring the Terminal

The configuration information for WinIATE is normally kept in either the IATE.INI file (the
default configuration file name) or in the file whose name was specified by using the “-i” option
on the command line of the program item or shortcut for the terminal emulator.  In either case, the
terminal configuration file must reside in the \WINDOWS directory (or the \WINNT40 directory
under NT).  This configuration data is normally maintained by the use of various configuration
menus and dialog boxes in the WinIATE software.  This file may also be edited with a text editor.
Before editing this file, first make a backup copy.  When finished editing the file, be sure to save
it as a plain ASCII text file.  (If using a text-only editor such as EDIT or NOTEPAD, use its
standard Save command.  Alternatively, if using word processing software to edit the file, it may
be necessary to use a special form of the word processor’s Save command to save the file as “text
only” or “DOS text”.)

Use the “Configure Link” option in the File Menu to set or change the connection to the
gateway.  

Use the “Configure Terminal” option in the File Menu to customize the terminal’s parameters.

______________________________________________________________________________
Creating and Using WinIATE Shortcuts/Program Items

To set up a program group for WinIATE when using workstations running Windows 3.1 or
WFW,  use the New command in the Windows Program Manager’s File menu and create a new
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Program Group named WinIATE (or any valid Windows name).  Then use the New command
again to create a Program Item (icon) to invoke WinIATE.  In the Description field of the
Program Item Properties dialog enter: WinIATE.  In the Command Line field, enter: winiate.exe.  In
the Working Directory field, enter the name of the WinIATE installation directory, e.g. c:\winiate.
(Do not turn on the Run Minimized check-box button.)  (Refer to the Windows documentation for
more information on how to create new program groups and items.)

For workstations running Windows 95 or NT, use the Windows 95/Windows NT Explorer to
create a shortcut.  (Refer to the Windows documentation for more information on how to create a
new shortcut.)

The name of the default configuration file used by WinIATE is “IATE.INI”.  When running
multiple copies of WinIATE, each copy of the terminal must specify its own configuration file
name by using the “-i” command line option.  This is done to set up multiple host configurations,
for example, or to run multiple terminals on the same host.  To set up multiple copies, start by
deleting the IATE.INI file.  Make a copy of the WinIATE program item/shortcut, or make a new
program item/shortcut as before.  In the new program item/shortcut’s Properties dialog, change
the Description entry to a name such as SABRE WinIATE.  Also, change the Command Line entry
to include the option “-i” followed by the name of the new configuration file, for example:
winiate.exe  -iklmcfg.  Use the new program item/shortcut to run WinIATE.
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Using the Terminal

While the airline host system itself hasn’t changed, the power of the PC and Windows has been
leveraged to make working with the host easier and more efficient.  This section describes the
WinIATE windows and menus, and explains how to use the terminal. 

The first time WinIATE is started, it will ask for information about connecting to the gateway and
then display a window where entries can be made and host responses are received.  The terminal
displays status information (such as Sys Avail) and any broadcast messages from the airline host in
either a smaller, free-floating window  (the “Status Window”) or in a fixed Status Bar that is
displayed, as configured by the user, at either the top or the bottom of the Terminal window. 

Terminal windows are normally 64 columns wide, but some hosts can accommodate up to 80
columns per line of text.  The maximum number of rows in the window is 32.  Host entries and
responses appear inside terminal windows.  An entry is sent to the host each time the Enter key is
pressed.  Until a response is received from the host, the keyboard is locked and will not respond to
operator input, with the exceptions noted below.  When the terminal receives a message from the
host, the message appears in the current terminal window, and the keyboard becomes active again.

If the keyboard remains in the “Locked” state, it is possible for the operator to unlock the
keyboard by pressing the “reset” key (usually on the “Escape” key).  This is typically necessary
when:

• A message to the host has been lost in transit.  This can be caused by a number of factors,
most commonly noise on the communication line.  Regardless of the cause, the host will not
respond to a lost message; this means that without the operator taking special action, the
keyboard will remain locked indefinitely.  To break out of this locked state, press the Reset
key (usually Esc).

• A message from the host has been received in a garbled state.  In this case the Request Repeat
(Push Rpt) message appears in the status window.
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__________________________________________________________________________
The Status Area

The status area may either be configured as a free-floating window or as a fixed line in the
terminal window.  When the Status area is configured as a free-floating window, the first line
inside the Status Window displays information about the status of the session with the airline host.
The status messages that may be displayed here include: 

Sys Avail The host system is available for use.  “Sys Avail” is displayed on a green
background.

Sys Unavail The system is not available for use.  If the host is down, “Sys Unavail” is
displayed on a yellow background.  If the terminal  cannot make a connection
to the gateway or the terminal has lost its connection to the gateway, “Sys
Unavail” is displayed on a Red background.

Kybd Locked A message or command has been sent to the host, but a response has not yet
been received.  If no response arrives from the host, the terminal’s Reset key
(usually mapped to Esc on the keyboard) may be pressed to unlock the
keyboard.

Timer  Displays how many seconds the keyboard has been in the locked state.

Push Rpt This message appears when:  (1) the terminal has received a message from
the host with an error, or  (2) a message from the host is longer than the
window size the operator has selected, or  (3) the message from the host has
invalid screen positioning commands.  If this message appears, press the
Reset key and then re-enter the last command.

Umsg  The terminal has received an unsolicited message indicator from the host.
Press Ctrl-U to display the text of the unsolicited message.

ReEnter Data cannot be sent to the host.  If this message appears, press Reset and re-
enter the last command.  This is usually caused if there is no SOM on the
screen when the Enter key is pressed.

Insert Indicates that the terminal is in insert mode.  Any characters typed will be
inserted between the existing characters as long as this message appears in
the Status Window.  Each line can accommodate a maximum of 64 (80 for
selected hosts) characters.  Any characters pushed to the 65th (81st) column
when in the insert mode are lost.

Recording  The user has selected “Start PF Recording” from the “Options” Menu and the
terminal is now recording all keystrokes made by the user.

The Broadcast Message Area occupies the lower portion of the Status window.  It is used for
two purposes:  (1) to support special message functions; and (2) to display prompts used during
execution of programmable function keys.
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The Status Area is normally a floating window.  However, it will appear as a fixed line in the
parent window if “STATUSBAR=TRUE” appears in the “[terminal]” section of the configuration
file.  When using the “Status Bar” option, the parameter “STATUSONTOP=TRUE” (or FALSE)
controls whether the Status Bar appears at the top or at the bottom of the WinIATE window.  The
Status Bar has the following format, with the same indicators as described above.  

SysAvail   KbdLocked   Timer   PushRpt  ReEnter   Umsg  Insert   Record   (Broadcast Msg Area)
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__________________________________________________________________________
The Terminal Window

Host entries and responses appear in the Terminal Window.   All the same Host commands that
users normally enter are used.  Only now there are a variety of additional Terminal commands that
will save time and effort in many routine tasks.  Most of them are readily available on one of the
Terminal’s pull-down menus, by a single keystroke, or by a double keystroke combination.

Viewing recent Host entries - When the mouse pointer is in a Terminal window, clicking the right
mouse button while pressing the Alt key causes a pop-up menu to appear. (Pressing Control-H or
selecting “Command History” under the “Options” Menu also causes this pop-up menu to
appear.)  This menu contains the most recent entries that have been sent to the Host . The default
number of entries in this menu is 15.  This number may be changed to be as many entries as
desired (by selecting the “Configure Terminal” item on the “options” menu).  Selecting an entry
from the pop-up menu will cause a SOM and the entry to be placed either at the current cursor
location in the active Terminal window or on the next line in the active Terminal window. (On
longer entries, only the first 20 characters of the entry are displayed in the menu, but the entire
entry is placed in the terminal window if the entry is selected.)

Host Output Routing may be used to send host output to a different window than the window the
entry was typed into.  This function will not work unless the “[terminal]” section of the
configuration file includes the line “ENTERWINDOWROUTE=TRUE”.  Press Control-1, -2, -3,
or -4 to send the host response to window 1, 2, 3 or 4 respectively (shown as “Rt1”, “Rt2”, Rt3”,
and “Rt4” on the keyboard map).

Multiple Windows are available.  As many windows can be opened as there is memory available.
In most configurations, ten windows can be opened before it is necessary to allocate more
memory to the terminal.  To move between windows, select the window from the pull-down
menu; use a keyboard shortcut, or click on the window.  The windows retain their host entry and
response text even when the window is not visible.  The terminal can be configured (using the
“Enter Change Window Action” command on the Options pull down menu) to send one or more
entries to the Host when switching between windows (this is most commonly used to change work
areas when switching between windows).

The host considers the user’s terminal to be a single display.  Host responses appear in whichever
terminal window is in the foreground when the response arrives.  So, for example, if a user makes
an entry in Window 1 and then switches to Window 2 before the response appears, the host
response is displayed in Window 2.  

The New Window command (in the File menu) opens a new, empty terminal window and places
the cursor at the home position.  The number of the window is usually shown in the Title bar.  The
user can control the name assigned to the window by using the “Set Window Name...” function in
the terminal’s “windows” pull-down menu.

The Close Window command (in the File menu) removes the current window, discarding any
information that was displayed in that window.
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______________________________________________________________________________
Keyboard Functions

The following keys correspond directly with the symbols on the key caps of the keyboard of the
PC, and will be displayed when the key is pressed:

ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 -  /  .

A number of special purpose keys and messages are used for airline terminal emulation.   These
include:

Change/Pillow/Lozenge: This is normally the [ key or the @ key.  It appears as  or @ on
keyboard maps and on the screen.

Cross of Lorraine: The ' key generates the Cross of Lorraine (for SABRE only).  It appears
as  or ¥ on keyboard maps and on the screen.

Display:  This is the = key.  It may also be on the * key.  It appears as * on
keyboard maps and on the screen.

End Item: This is the \ or , key.  It appears as ∑ or # on keyboard maps and on the
screen.

Enter: This is the Enter key.  Use this to send an entry to the host.

Field Mark: This is FMk on keyboard maps.  It appears as  on the screen.

Function Keys: These are F1 - F30 on keyboard maps.  Use these to execute the
indicated PF Key.

Optional Field: This is Opt on keyboard maps.  It appears as  on the screen.

New Line: This is NL on keyboard maps.  It appears as a right triangle on the
screen.

Payment (Pricing): This is the $ key.  It appears as $ on the screen.

Print Enter: This is PrEnter on keyboard maps.  On some hosts, this key is used to
send an entry to the host and have the response sent to the currently
assigned hardcopy printer instead of to the terminal window. 

Route to Window #1: This is Rt1 on keyboard maps.  It performs the ENTER function and
sends the response to window #1.

Route to Window #2: This is Rt2 on keyboard maps.  It performs the ENTER function and
sends the response to window #2.

Route to Window #3: This is Rt3 on keyboard maps.  It performs the ENTER function and
sends the response to window #3.
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Route to Window #4: This is  Rt4 on keyboard maps.  It performs the ENTER function and
sends the response to window #4.

Start of Message: This is SOM on keyboard maps.  It appears as  on the screen.

Reset: This is Res on keyboard maps.  It is usually on the Esc key.  Use it to
unlock the keyboard (to get out of the Keyboard Locked state) or to
break out of a PF key or script.

Reenter: This is ReE  on keyboard maps.  When the last entry sent to the host is
still visible in the terminal window, press this key to send that entry to
the host again.  This key only works on certain host types.

Unsolicited Message: This is Ums on keyboard maps.  If the “Umsg” indicator is displayed in
the status window, press this key (or key combination) to have the host
send the Unsolicited Message to the terminal window.

Several keys are used for cursor and screen control.  These include:

Arrow Keys: These keys move the cursor one row/column in the direction of the
arrow.   

Back Tab: This is <Tab on keyboard maps.  It moves the cursor to the first tab
position to the left of the current cursor position.   

Bottom Edge: This is Bot on keyboard maps.  It moves the cursor straight down from
its current position to the bottom of the current window.   

Beginning of Line: This is BOL on keyboard maps.  Use this key to move the cursor to
column 1 of the current line.

Clear: This is Clr on keyboard maps. It erases the data in the active window;
puts a SOM in row 1,  column 1 of the active window; and positions the
cursor to the right of the SOM.

Clear Broadcast: This is CBr on keyboard maps.  Use this to clear the broadcast message
currently displayed in the status box.

Display Carriage Returns: This is FOS on keyboard maps.  On some hosts, this key can be used
to toggle in and out of the modes which display or do not display the
“SOM” and “carriage return” characters.

Echo: This is Ech on keyboard maps.  It turns keyboard echoing on and off.
It is most commonly used to hide the entry of a password.

Eighty Columns: This is 80 on keyboard maps. On some hosts, it toggles the width of the
window between 64 and 80 columns.

End of Line: This is EOL on keyboard maps.  Use this to move the cursor to the end
of the data on the current line.
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End of Screen: This is End on keyboard maps. It moves the cursor to column 64 (80)
of the last row in the current window.

Full Screen: This is Ful on keyboard maps.  On some hosts, this key is used to go
out of split screen mode and into full screen mode.

Go to Window #1: This is Wn1 on keyboard maps.  It brings window #1 to the foreground.

Go to Window #2: This is Wn2 on keyboard maps.  It brings window #2 to the foreground.

Go to Window #3: This is Wn3 on keyboard maps.  It brings window #3 to the foreground.

Go to Window #4: This is Wn4 on keyboard maps.  It brings window #4 to the foreground.

History: This is His on keyboard maps.  It displays the recent entries that have
been made.  The user can then double-click on an entry to display it in
the terminal window.

Home: This is Hom on keyboard maps.  It moves the cursor to row 1 column 1
of the active window.

Last Message: This is LMg on keyboard maps.  Use it to redisplay the last message
sent to the host.

Left Edge: This is LEd on keyboard maps.  It moves the cursor left from its
current position to left edge of the current window.   

Next Window: This is NxW on keyboard maps.  Use this to move to the next higher
numbered window on the screen.

Previous Window: This is PvW on keyboard maps.  Use this to move to the next lower
numbered window on the screen.

Protected Mode: This is Pro on keyboard maps.  Use this to toggle in and out of
protected screen mode.  Protected mode is only active if it is turned on
1) by a PF Key script or 2) by certain masks sent from the host.

Right Edge: This is REd on keyboard maps.  It moves the cursor right from its
current position to right edge of the current window.   

Split Screen: This is Spl on keyboard maps.  On some hosts, this key is used to go
out of full screen mode and into split screen mode.

Tab: This is Tab on keyboard maps.  The Tab key moves the cursor to the
next tab position in the current window.

Top Edge: This is Top on keyboard maps.  It moves the cursor straight up from its
current position to top of the current window.   
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Keys used to edit text in the terminal screen include:

Copy: This is Cpy on keyboard maps.  Use it to copy any highlighted text
displayed on the screen and place the text in the Windows clipboard.

Cut: This is Cut on keyboard maps.  Use it to remove any highlighted text
from the screen and place the text in the Windows clipboard.

Delete: This is Del on keyboard maps.  It deletes the character at the cursor
position, and moves all characters to the right of the cursor (on the same
line) one column to the left.

Delete Line: This is DLn on keyboard maps.  It deletes the line that includes the
cursor. 

Erase: This is Ers on keyboard maps.  Use this to erase the character to the left
of the cursor.  In addition, the cursor moves one position to the left.

Erase to end of Line: This is EEL on keyboard maps.  It erases all characters between the
cursor and the end of the line.

Erase to end of Page: This is EEP on keyboard maps.  It erases all characters between the
cursor and the end of the window.

Insert character: This is Ins on keyboard maps.  It toggles the terminal between Insert
Mode and Overstrike Mode.  When the terminal is in Insert mode,
characters shifted right past the 64th (or 80th) column are lost.  In
Overstrike mode, each character typed overwrites any character that had
previously occupied the same position in the window.

Insert Line: This is ILn on keyboard maps.  It inserts a new line at the cursor
position. 

Paste: This is Pst on keyboard maps.  Use it to copy the text that is currently
in the Windows clipboard to the current cursor location on the screen.

Select: This is Sel on keyboard maps.  It is the standard Windows function
using the shifted arrow keys to highlight text on the screen.   
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_____________________________________________________________________________
The File Menu

The File pull-down menu contains the commands shown in the picture below.

 PF Keys    Options  Text  Window    Help  File   

New Window
Close Window
Next Window
Previous Window

Find Status Window
Find PF Key List Window

Print Window to Local Printer
Print Window to Remote Printer
Cancel Remote Printing in Progress

Configure Link...
Configure Terminal

Load PF Keys
Save PF Keys

Print PF Keys to Local Printer
Print PF Keys to Remote Printer

Launch Application

Exit

 Edit   
InnoSys Airline Terminal

New Window Opens a new terminal window (on the same TA and work area) for the
currently active Host session.  The new window becomes the current terminal
window: in front of any others, ready to receive keystrokes and display host
responses. 

Close Window Closes the current terminal window.  This is equivalent to double-clicking on
the horizontal bar at the upper right corner of the current terminal window, or
selecting Close from its Terminal Window Control Menu (described later in
this document).
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Next Window The window with the next-higher window number becomes the current
terminal window: in front of any others, ready to receive keystrokes and
display host responses. 

Previous Window   The window with the next-lower window number becomes the current
terminal window: in front of any others, ready to receive keystrokes and
display host responses. 

Find Status Window  Brings the Status Window to the foreground.  This option is useful if the
Status Window has been obscured by other windows.  This will happen only if
the STATUSONTOP and STATUSBAR options are both set to FALSE in the
configuration file.  If the STATUSONTOP option is set to TRUE, then the Status
Window is always visible in the foreground; if the STATUSBAR option is set to
TRUE, then there is a permanent status bar instead of a status window; in either
case this menu command is not used.

Find PF Key List Window  Brings the PF Key List Window to the foreground.  This option is
useful if the PF Key List Window has been obscured by other windows.  See
the “View PF Key Labels” description under the “Options” menu for more
information on configuring the PF Key List Window, in particular the
PFKEYLISTMDI option.

Print Window to Local Printer  Prints the contents of the current terminal window on the default
Windows printer configured on this PC.  The default printer is selected using
the Windows Control Panel’s Printer configuration.  Refer to Windows
documentation or on-line help for details.

Note: To capture an image of the current terminal window as a graphic, begin
by positioning the terminal window in the upper left corner of the main
WinIATE window area.  (If necessary, move the terminal window to place it at
the upper left corner of the main WinIATE window.)  Press Alt-Print Screen.
This copies an image of the WinIATE window into the Windows Clipboard.
Start the Windows Paintbrush program (or another similar program).  Select
"Paste" from the Edit menu.  An image of the  WinIATE window should
appear within Paintbrush.  If nothing appears, try this procedure again, but this
time using Shift-Alt-Print Screen instead of Alt-Print Screen.

Print Window to Remote Printer  Prints the contents of the current terminal window to the printer
TA defined by the Printer Object Name in the link configuration (see Configure
Link below).  Note that the printer TA object must be accessible through the
same Gateway that the current terminal is linked to.

Cancel Remote Printing in Progress  Terminates the printing of the contents of the current
terminal window to the remote printer TA defined by the Printer Object Name
in the link configuration.

Configure Link Presents a dialog box that allows the user to enter the CRT link configuration
information: CRT Object Name, Service Name, and Gateway Host Name.
Optionally, the user can also enter the Printer Object Name (this is the name of
the printer object for the Print Window to Remote Printer command in the File
menu).  If the CRT Object Name is entered as “*”, the terminal will attempt to
link to any free dynamic TA at the gateway.  Press the OK button to confirm
the new settings, or Cancel to cancel changes.  This dialog box also displays the
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host type of the gateway the terminal is connected to and the terminal’s IA and
TA.

Configure Terminal  This window allows the user to make selections for a number of configurable
items, including number of rows and columns; font (use the “IATE” font for
SABRE; use the “ALC” font for all other hosts); the number of previous
commands the terminal will recall; the UMSG character; and whether to show
the return character for certain host types.  If the status area is a floating
window, “Status Window Always On Top” forces it to remain on top of the
other windows.  If the status area is a fixed bar, “Status Window Always On
Top” controls its placement at the top or bottom of the window.

Configure Terminal

Cancel

Show Returns

Status Window Always On Top

Change Font

Columns

Rows

UMSG Character

Command History ListSize

Size:   8

Font:   IATE

25

U

20

64

Startup Action

Shutdown Action
(0 = disabled)

Inactivity Shutdown Timer Min

OK

There are three fields at the bottom of this configuration screen that are of
particular interest to users who use “dynamic” or “pooled” TAs.  “Startup
Action” lets the user select a script to execute when the terminal first starts up.
Such a script would typically do an ignore, then a sign-off, then a sign-on.
“Shutdown Action” lets the user select a script to execute when the terminal
application is exited.  For example, such a script might do an ignore, then a
sign-off.  (For more information on scripts, see the “PF Keys and Scripting”
manual.)  The “Inactivity Shutdown Timer” lets the user specify how long his
terminal should run before it automatically quits because the user has not sent
any entries to the host.  A warning message is displayed just before the terminal
quits.

When using a Startup script, it is VERY important that the first part of the
script include code to verify that the host system has come up before an entry is
sent to the host system.  A simple way to do this is to use the PF key “Pause”
command, specifying a pause of one or two seconds.  A more robust way to do
this is to use the “HOSTAVAILABLE” system variable, as follows:
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^\WHIL (HOSTAVAILABLE=0)^
^P1^

^\ENDW^

Load PF Keys This selection allows the user to select a bank (file) of PF keys to be loaded
from the local PC or from a fileserver using the dialog box shown below.  The
default path for loading the PF keys is set by the “PFKEYFILENAME=” line
in the “[terminal]” section of the configuration file.

Open

Cancel

OK

*.pf

File Name

Calc.pf
Hotels.pf
qa.pf
sample.pf

Help

Folders

c:\winiate

C:\
winiate

fonts
addons

Read Only

List files of type Drivers

C:bigdisk
Network

?

PF Key File

Save PF Keys This selection allows the user to save a bank (file) of PF keys on the local PC
or on a fileserver.  The user selects where to save the keys by using the dialog
box shown below.  The “PFKEYFILENAME=” line in the “[terminal]” section
of the configuration file sets the default path for saving the PF keys.

PF Key File

Save As

Cancel

OK

*.pf

File Name

Calc.pf
Hotels.pf
qa.pf
sample.pf

Help

Folders

c:\winiate

C:\
winiate

fonts
addons

Read Only

List files of type Drivers

C:bigdisk
Network

?
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Print PF Keys to Local Printer  Prints the current bank of 30 PF Keys on the default Windows
printer configured on this PC.  The default printer is selected using the
Windows Control Panel’s Printer configuration.

Print PF Keys to Remote Printer  Prints the current bank of 30 PF Keys to the printer TA defined
by the Printer Object Name in the link configuration.  The printer TA object
must be accessible through the same Gateway that the current terminal is linked
to.

Launch Application  This selection displays a sub-menu which allows the user to select an
application to be launched directly from the terminal.  A new copy of the
application is launched each time this item is selected.  “Launchable”
applications are created by defining them in the “launch” section of the
configuration file.  Below is an example of the launch section of a
configuration file which defines two launchable applications, “Calculator” and
“Calendar”.

[launch]
Calculator=SciCalc c:\windows\calc.exe
Calendar=CalWndMain c:\windows\calendar.exe

The parameter on the left side of the "=" has two functions:
   i) it is used as the name that will appear in the launch sub-menu of the File
menu; and
   ii) it is used whenever the PF key "Launch" function (“ X.... ”)is executed,
as follows:  the “Launch” function compares its operand with the names in this
section of the configuration file and if “Launch” finds a match, it runs the
program with the given class name.

The first parameter on the right side of the "=" is the Windows “class name” of
the program described by the parameter on the left side of the "=".  The second
parameter is the application’s fully-qualified path.

Exit This command quits the WinIATE application.  This is one of four ways to
quit the program.  This command is equivalent to the Close command in the
Main Window Control menu.  A third way to quit is to double-click on the
horizontal bar at the upper left corner of the main WinIATE window.  The
fourth method is to press Alt+F4.  All of these methods are equivalent; any one
of them can be used to quit the program.
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______________________________________________________________________________
The Edit Menu

The Edit pull-down menu contains the following commands:

 File   

Cut
Copy
Paste
Clear

Select All

Column Copy
Add Returns to Copies

 Edit    PF Keys    Options  Text  Window    Help 
InnoSys Airline Terminal

Cut Removes the selected text from the current terminal window and places it on
the Windows clipboard.

Copy Copies the selected text from the active terminal window and places it on the
clipboard.  The “original” text stays where it was when it was selected.

Paste Copies the text from the clipboard to the current terminal window, beginning at
the current cursor location.

Note:  Each time Cut or Copy used, the previous text in the clipboard is
forgotten.  So, if it is necessary to paste multiple blocks of text, the user must
Cut or Copy and then Paste each block in turn.

Clear Removes the highlighted text from the current terminal window without
placing the text on the clipboard.  The removed text is completely deleted and
forgotten.  The cursor is positioned where the deletion started.

Select All Selects all the text in the active terminal window.

Column Copy Switches the Terminal between line-copy and column-copy modes. In column-
copy mode, individual columns may be selected.  When in Column Copy
mode, a check mark (“√”) appears to the left of this command.  To use this
function, enable Column Copy first, then select the text to be copied.  The Cut
and Paste commands will not work while in column-copy mode.

Add Returns to Copies  Ensures that there is a carriage return at the end of each line being copied
out of the window.  While the Add Returns to Copies function is on, a check
mark (“√”) appears to the left of this command.
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______________________________________________________________________________
The PF Keys Menu and Dialog

The PF Keys pull-down menu displays a list of all the PF keys that have been defined, including
the label if it was included in the PF Key definition.  Selecting a key from this list executes the PF
key.  (PF Keys can also be executed directly from the keyboard.)  Keys 1-12 are normally mapped
to function keys F1 through F12.  Keys 11-20 are normally mapped to Shift-F1 through Shift-
F10.  Keys 21-30 are normally mapped to Control-F1 through Control-F10..

 File   

01  Fares Help
02  PNR
03  JFK Avail
04  Ticketing
05  Move Profile
06  Hotel Avail

 Edit    PF Keys    Options  Text  Window    Help 
InnoSys Airline Terminal
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______________________________________________________________________________
The Options Menu

The Options pull-down menu contains the following commands:

 Options Edit    File   

Define PF Keys...
Start PF Recording...
Enter Change Window Action...
Command History...
View PF Key Labels

 PF Keys    Text  Window    Help 
InnoSys Airline Terminal

Define PF Keys Presents a dialog box in which the user can view and edit the definitions
of Programmable Function Keys (PF Keys).

Define Function Keys

Key Number: Label:

Host

Text:

1 Rec'd From

Wait SOM&Insert

Ascii Keyboard Mode

Commands:

All Commands:

Menu Commands (^M):

Language Commands:

Enter

Quit Save/QuitSave

^SRR:LDW^E

* - Insert Comment

A - All Data

NWWN - New WIndow

To edit a function key definition from #1 through #30, enter the key number into the Number
field, and then press the Tab key.  Enter a short descriptive name into the Label field.  Press Tab
again and enter programmable function key commands into the Text area.  To save the new
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definition, click the mouse on the Save button, or press Tab once more and then Enter.  To
define another key, return to the Number field, enter a new key number, and repeat the procedure.
When finished, use the mouse to click on the Save/Quit button; or use the Tab key to move on to
that button and then press Enter.  Use the Quit button to avoid saving the last definition edited.  To
Cut, Copy, and Paste in the Define Function Keys dialog box, use:

Function Ascii Keyboard Mode checked Ascii Keyboard Mode not checked
Cut Ctrl-X Shift-Del

Copy Ctrl-C Ctrl-Ins
Paste Ctrl-V Shift-Ins

The Ascii Keyboard Mode box, when unchecked, restricts the character set for defining PF keys
to the characters that can be sent to the host.  When the Ascii Keyboard Mode box is checked,
any character may be entered into a PF key definition.  Refer to the “PF Keys and Scripting”
manual for further information on how to program and use Function Keys.

PF key scripts that are created inside the “Define Function Keys” window can be up to 256
characters in length.  A PF key script file (launched with the ^X function) can be any length; the
limiting factor is the amount of available memory in the PC at the time the file is loaded.  The
entire file is read into memory before it is executed, and even more memory is used once the
script is executed.  In general, users should verify there is more than enough free memory to fit
the file and the subsequent execution.  The Program Manager “About Box” displays the amount
of free memory available at any given time (this value includes any virtual memory configured in
the PC as well as real memory).

Note:  When the IATE Gateway is not available, the function key definitions may not be editable
for several seconds.  Also, the definitions cannot be edited while a programmed function key is
executing the “^W” (Wait) function.   If it is not possible to edit PF key definitions in the dialog
box, press the Quit or Save/Quit button, press the Esc key, wait a few seconds, and then try again.

Start PF Recording When “Record Function Key” is selected, all entries made by the user
in a Terminal window are saved as function key text to the function key
or the file specified.  Click on either the “Key Number” or the “File
Name” button to specify where the function key text should be saved;
then in the box enter either a key number or a file name.  If a key
number is entered, a label for the PF key can be entered in the “Label
Text” box.  Click on “Start Recording” when the setup is complete.

PF Key Recording Setup

Key Number

File Name...

Label Text:

Cancel Start Recording
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After clicking on “Start Recording”, the dialog box goes away, and the “Start Recording” in
the Options Menu changes to “Stop Recording”.  The recording function continues until the
entries to be record are complete and “Stop Recording” has been selected from the Options
Menu.

Enter Change Window Action  Lets the user specify one or more actions to be performed when the
user changes to this window, such as changing to a different work area.
Any one or more action(s) that can be described in PF Key text can be
performed.  Refer to “Define PF Keys” above for how to use this dialog
box.  Use of this function adds a file called WINIATE.WCA to the
WINIATE directory.

Enter Change Window Action

Window Number: Label:

Host

Text:

3

Wait SOM&Insert

Ascii Keyboard Mode

Commands:

All Commands:

Menu Commands (^M):

Language Commands:

Enter

Quit Save/QuitSave

^SR^C*SC^E

* - Insert Comment

A - All Data

NWWN - New WIndow
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Command History Presents a dialog box which contains the most recent entries made in
the terminal window (the maximum number is configured in the
“Configure Terminal” dialog box.)  The user can select any of the
commands shown to redisplay in the terminal window.

Command History

JT9F231A
G*ORD/2FEB
WEA*DSM
JS*DSM
FQORDDSM
VIPS142

OK Cancel

View PF Key Labels Presents a dialog box from which the user can select any of the PF Keys
shown to execute that key.  To have the PF keys dialog box behave as a
“Child” Window inside WinIATE’s “parent” window, the line
“PFKEYLISTMDI=TRUE” must appear in the “[terminal]” section of
the configuration file.

PF Keys

01
02
03
04
05
06
07

hotels inq
sell hotel
add rm type
cred card
guarantee
itin remark
cancel hotel

- x
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______________________________________________________________________________
The Text Menu and the Font Dialog

The Text pull-down menu contains commands to select the character font, font size, and style for
all terminal windows, and additional commands to select the color of the displayed font.

 File   

Font...

Red
Green
Blue
Cyan
Yellow
White
Black
Default Color

 Edit    PF Keys    Options  Text   Window    Help 
InnoSys Airline Terminal

The Font command brings up a dialog box, as shown on the next page. Using this dialog
box, the user can select three font characteristics:  the Font Name, Font Style, and Font Size.  This
dialog box uses a standard Windows font dialog format that is similar to those used in Windows
word processors.  A list of font names appears on the left, styles appear near the center, and sizes
are listed toward the right side of the dialog box.  On the far right side of the dialog box are the
OK button to confirm, and Cancel to cancel changes.  On the lower right, an area labeled Sample
will display an example of any selected font and style.

In addition to the fonts supplied with the WinIATE terminal (“ALC”, used for all hosts except
SABRE and “IATE”, used for SABRE), other Windows fixed-pitch (or variable-pitch) system
fonts can also be used.  This is not generally recommended since the system fonts do not support
special airline terminal character sets.  Also, if a variable-pitch font is used, then data on many
screen displays will not “line up” properly.  When using the InnoSys fonts, which are not fully
scalable, two or three actual usable sizes are available, depending on the monitor.  The
normal/boldface option gives the user additional control over the font’s appearance.

When the font selection is changed, WinIATE immediately changes the font characteristics in all
open windows.  If desired, the user can then resize the windows by hand, or change the font
selections again, if necessary, to obtain the best available display.
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Font

Font: Font Style: Size:
OK

Cancel

Sample

Script

OEM/DOS

IATE
ALC
Courier
Courier New
IATE

TT

+ Regular
Italic
Bold
Bold Italic

IATE
+

8

8 +

?

Font:
Click on any one of the selected font names.  Use the scroll bar beside the list of names to
move up and down through the list.  Use the IATE font for SABRE host connections; use the
ALC font for non-SABRE host connections.  Any other font listed in the dialog box can be
used, but these fonts will not properly display the airline host system character set.

Font Style:
Click on either Regular or Bold style.  Do not select the italic styles; WinIATE will not display
italics correctly.

Size:
Disregard the displayed list showing one or more available sizes.  Instead, click the mouse on
the boxed area immediately beneath the word “Size”, and enter a size of approximately 8 (for
a small font appearance) or approximately 18 (for a larger appearance).  Press Tab after
entering the value, and an example of the font’s appearance is displayed in the Sample area.
To change the value again, click the mouse in the Size box again, enter a new value, and press
Tab again.

Since the InnoSys fonts are not fully scalable, small changes in the Font Size entry will
generally not change the actual size.  After experimenting with different size values, the user
will probably find that there are two usable sizes, or three if a high-resolution display
configuration (1024x768 or greater) is being used.  Note: Selecting the Bold style may make
a small font appear clearer on some displays.

Sample:
This area displays sample text in the font the user has chosen (above).
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Script:
This area displays the type of font the user has chosen (above).  The two most common types
are “western” and “OEM/DOS”.

The remaining items in the Text menu are color names.  These allow the user to select the font
color for the currently active terminal window, in a manner similar to the color items in the
Window menu.

Notes on Color Selections and Text Display Problems:

The font color is not selectable from within the Font dialog, as in some other application
programs.  This is because the WinIATE color selections are placed into the Text menu for
consistency with the Window menu, and to limit the available selections to a set of colors which
will appear clear and distinct in WinIATE windows.

If  the same color is selected for the font and the window background, text will not be visible.
WinIATE does not guard against this.  If it is likely that text is present in the window but is not
visible, check to make sure the window and text colors are different (or both set to “Default
Color”, which generally should work).  If the color selections are not the cause of the problem, it
is possible that the only text on the screen is in a SABRE protected field where text is not visible,
or the “Echo characters/Don’t Echo characters” toggle is set for “Don’t Echo”.  Also verify that
the host connection is still available and that the keyboard is unlocked, so that new text (from the
host or keyboard) can appear.
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______________________________________________________________________________
The Window Menu

The Window pull-down menu contains commands to control the visibility of Carriage Returns,
to place terminal windows into “cascaded” or “tiled” arrangements, to set the current terminal
window’s background color, and to select any one of the currently open terminal windows.  

 Options File   

Show Returns

Cascade
Tile Horizontally
Tile Vertically

Window Title

Red
Green
Blue
Cyan
Yellow
White
Black
Default Color

1 IATE Window 1
2 IATE Window 2

 Edit    PF Keys    Text  Window    Help 
InnoSys Airline Terminal

√

√

√

As discussed earlier, some hosts require that carriage returns (at the end of each line) be visible to
the user.  The first  item in the Window pull-down menu lets the user toggle between the visible
and invisible mode for carriage returns.  A check-mark (“√”) appears next to this item if the option
is set so that carriage returns are visible.

The Cascade and Tile commands arrange the terminal windows within the main IATE window.
Cascade overlaps the windows to give a “stacked” appearance.  Tile places the windows
horizontally and vertically with no overlap.  The best way to see what these commands do is to try
them. (These commands have no effect if there are no terminal windows open.  If just one
terminal window is open, Tile will cause that window to fill the main window.)

The Window Title selection displays a dialog box allowing the user to set the name of the Terminal
window this function is invoked from.  Any name can be used, such as “Hotel Window”,
“WorkArea A”, etc.  There are two special characters provided that are useful in defining window
names.  If the “:” character is entered, then the Terminal emulator configuration file name is
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inserted in that location in the window name.  If the “^” character is entered, then the window
number is inserted in that location in the window name.

The use of colors in the Window menu allow the user to select the background color in the
currently active terminal window.  To change the color for a different window, select that window
first (click on the window or select it from this menu).  If “Default Color” is selected, the window
will take on the current system default color for window backgrounds as set in the Windows
Control Panel.

The remaining items in the Window menu, if any, represent a list of the currently open terminal
windows.  These items let the user select which one of the currently open terminal windows to
use. When a window is selected from this list, it becomes the current window, with a highlighted
border, in front of any other terminal windows.  In the menu, a check-mark (“√”) appears next to
the currently selected window number.

Another way to bring a window to the front is to click on it, if it is at least partially visible behind
the other window(s).  If a window has been converted to an icon, double-click on the icon to
convert it back into a window and bring it to the front.  There are also keyboard shortcuts
available to move between windows.

Note:  The Window menu does not contain the commands to open and close terminal windows.
Refer to the earlier discussion of the File menu for information about the New Window and Close
Window commands.
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__________________________________________________________________________
The Help Menu

The Help pull-down menu contains commands to display information about the WinIATE
software.

 

 Window    Help  File   

WinIATE Help...

About WinIATE...

 Edit    PF Keys    Options  Text 
InnoSys Airline Terminal

The WinIATE Help command gives the user additional information about the use of the WinIATE
software and how the various keys are used.  If desired, the user can make the Help function
available through the keyboard by modifying the Termkeys file.

The About WinIATE command displays the version number of WinIATE.

About WinIATE

InnoSys Airline Terminal Emulator for Windows

OK

Copyright ©  InnoSys, Inc. 1991-1998 

Version 2.5
All Rights Reserved
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Appendix A — Common WinIATE Startup Errors

There are several errors that are quite common when the WinIATE software is started.  They
result primarily from i) incorrect host/services configuration and ii) files the terminal emulator
software cannot find as it starts up.  The most common errors and the primary reasons that these
errors occur are listed below:

“Host unreachable:  the specified Host system name was not found”
- WinIATE cannot find on the TCP/IP network a machine with the Gateway Host Name specified
in the “Configure Link” dialog box in the file menu.

“No Gateway of this name could be found.  Please check the gateway name or status.”
- WinIATE cannot find the “services” file.
- WinIATE cannot find in the “services” file the Service name specified in the “Configure Link”
dialog box in the file menu.

“Can’t connect to server:  socket-level connect failed”
- WinIATE cannot find the domain name server or the “hosts” file.
- The gateway machine is running, but the gateway is not running on the port (service name)
specified in the “Configure Link” dialog box in the file menu.

“You have attempted to open a Programmable Function key file that cannot be found”
- WinIATE cannot find the “startup” script file specified in the “terminal configuration” dialog
box in the file menu.

“Couldn’t open termkeys file”
- WinIATE cannot find the termkeys file.
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Appendix B — Installing Fonts (Windows 3.1 and 
Windows for Workgroups)

The WinIATE font file, IATE.FON,  contains fonts for use with the SABRE (the “IATE” font)
host and with non-SABRE (the “ALC” font) hosts.

The fonts are not required but are highly recommend for using WinIATE.  To install the fonts
under Windows 3.1 or WFW, follow these steps:

1. If the PC happens to have only a 5.25" floppy drive, it may first be necessary to transfer all
files from the 3.5" diskette to a 5.25" diskette.

2. Using MS-DOS, or an “MS-DOS Prompt” window in Windows, change to the Windows
System directory: C:\WINDOWS\SYSTEM.  Look for files named IATE.FON and/or
ALC.FON.  For example:

c:
cd \windows\system
dir iate.fon
dir alc.fon

If the IATE.FON and/or ALC.FON fonts are found, make a backup copy of the file(s)
before proceeding.

3. Start Windows, if it is not already running.  Double-click up the Windows Control Panel
icon, and then double-click on the control panel’s Fonts icon.  This should display a
window titled Fonts, with a list of Installed Fonts.  Scroll down through the list to find any
fonts whose names begin with “IATE” or “ALC”.  For each of these font(s), do the
following:

• Click on the font name in the list.  Double-check to make sure that the IATE or
ALC font are selected.

• Click the Remove button.

• Click the Delete Font File from Disk box, and then click the Yes button.

Double-check the displayed list of fonts, to verify that it no longer shows any IATE or
ALC fonts.

4. Now return to MS-DOS, or bring up an MS-DOS Prompt window.  Insert the floppy disk
into drive A: (or B:).  Copy the IATE.FON file from the floppy disk to the Windows
System directory, C:\WINDOWS\SYSTEM.  For example:

copy a:iate.fon c:\windows\system

5. Next, go back into Windows, and bring up the Control Panel’s Fonts window as before.
This time, click the Add button.   This should display a window titled Add Fonts.  Using
the Directories browser in the lower left corner of this window, change to the Windows
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System directory.  The current directory name, which is shown directly beneath the word
“Directories”, should then read “c:\windows\system”.

6. Still in the Add Fonts window, scroll down through the List of Fonts until a line is found
which reads:

IATE, ALC (InnoSys IATE fonts)

Click on that line, and then the OK button.  The Add Fonts window should disappear.
Then click the Close button in the Fonts window.

7. Before proceeding, exit and then restart Windows.

8. After restarting Windows, start WinIATE.  If no terminal window appears, select the New
command in the File menu.  While a terminal window is active, use the Font command in
the Text menu to bring up a font selection dialog.  Then select the IATE font (for SABRE)
or ALC (for non-SABRE host types), and set the font size and style.  For important details,
please refer to the description of the Text menu and the font selection dialog box, earlier in
this manual.

When typing text into a terminal window, or when the terminal receives text from a
host, WinIATE should display the text in the chosen font.  (The font shown in the
Status Window will not be changed.)
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Appendix C — Conventional (non-SABRE) Keyboard
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Appendix D — SABRE Keyboard
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Appendix E — Apiwatch utility program

The apiwatch utility program runs under Windows 3.1 and Windows for Workgroups only.  It
displays an ongoing report of activity over the API.  In addition, apiwatch can log activity
information to a file.   Apiwatch only runs reliably under Windows 3.1/3.1.1.

The most common way to run apiwatch is with its output sent to a viewable window and with the
diagnostic level set to “1010”, for example:

apiwatch.exe  -v1010

The command line options are:

Option Description Default value

-lname Log to file with prefix name.

-vxxxx debug output level xxxx  (in 0x000D (the 0x0001, 0x0004,
hexadecimal, from 0 to ffff).  and 0x0008 bits)
Set specific bits to show the follow-
ing types of debugging information:
0x0001 Network data transfer activities.
0x0008 Client-specific activity.
0x0010 Activity specific to API.
0x0020 Text of data messages.
0x0040 Errors (severe).
0x0080 Warnings (less severe).
0x0100 Timer-related activity.
0x0200 Network activity specific to

 the TLI transport interface.
0x1000 Buffer management activity.
0x2000 Buffer management debugging.
0x8000 Very verbose output.

-h Display the list of options.
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Appendix F — Sample Configuration File

Below is an example of a typical WinIATE configuration file.  The default name for this file is
“IATE.INI”.  While any of these parameters can be changed using a text editor, mistakes in the
configuration file can cause inexplicable errors and problems in the WinIATE software.
Therefore it is recommended that users only edit the items in the file that are not configurable
through the terminal software.  After editing the configuration file, be sure to save the file as
“text”.

[terminal]
ROWS=20
COLS=64
SHOWRETURNS=FALSE
STATUSONTOP=TRUE
MAXOLDCOMMANDS=50
UMSGCHAR=U
MAINPLACEMENT=1 171 408 -4 -4 20 15 613 414
STATUSPLACEMENT=1 111 343 -1 -1 114 355 628 452
PFLISTSHOWING=TRUE
STATUSBAR=TRUE
PFKEYFILENAME=C:\WINIATE\LDW
FONT=IATE
FONTSIZE=8
PFEDITASCIIMODE=FALSE
ENTERWINDOWROUTE=TRUE
STARTUPACTIONFILE=C:\WINIATE\STARTU.PFS
SHUTDOWNACTIONFILE=
INACTIVITYTIMEOUT=0
PFLISTPLACEMENT=1 176 346 -1 -1 538 24 655 448
PFKEYLISTONTOP=TRUE
WINDOWNAME=InnoSys Airline Terminal
PFKEYLISTMDI=TRUE
ENABLE_INACTIVITY_TIMEOUT_CHANGES=FALSE
DISABLE_LINK_CHANGES=FALSE
SOM_AFTER_RESET=TRUE
SPLASH_FILE=winiate.bmp
SPLASH_TIME=5
ADD_RETURNS_TO_COPIES=TRUE
TERMKEYS_FILE=termkeys

[launch] 
Calculator=SciCalc c:\windows\calc.exe
Calendar=CalWndMain c:\windows\calendar.exe

[gateway]
ZONENAME=baku
GATEWAYNAME=ialcserver
LINKNAME=termek14
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[printer]
PRINTERNAME=printerkl22

[window01]
BACKCOLOR=0x0000ffff
TEXTCOLOR=0x00000000
ACTIVE=1
#FONT=ALC
#FONTSIZE=8
WINDOWNAME=Thistle
PLACEMENT=1 -1 -1 -1 -1 88 88 690 388 1

[window02]
ACTIVE=1
#FONT=ALC
#FONTSIZE=8
PLACEMENT=2 171 261 -1 -1 36 75 638 375 0
WINDOWNAME=GP9 ^ :
BACKCOLOR=0x00ffffff
TEXTCOLOR=0x80000000

[window03]
ACTIVE=1
#FONT=ALC
#FONTSIZE=8
PLACEMENT=1 96 261 -1 -1 65 151 667 451 0
WINDOWNAME=Carrizozo Sub : ^
BACKCOLOR=0x0000ff00

[window04]
ACTIVE=0
#FONT=ALC
#FONTSIZE=8
WINDOWNAME=Leadville : ^ renamed
PLACEMENT=1 -1 -1 -1 -1 110 110 712 410 0
BACKCOLOR=0x00000000
TEXTCOLOR=0x00ffff00

[window05]
ACTIVE=0
WINDOWNAME=: -- Window ^
#FONT=ALC
#FONTSIZE=8
PLACEMENT=1 -1 -1 -1 -1 22 22 624 322 0

As mentioned above, some of these configuration options cannot be changed directly by the user
through dialog boxes or pop-ups.  The options that the user might want to change are as follows:

STATUSBAR=TRUE/FALSE  This option controls whether terminal status information is
displayed in a fixed Status Bar area or in a floating Status Window.

STATUSONTOP=TRUE/FALSE  When using a Status Bar,  this option controls whether the
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Status Bar is displayed at the top or the bottom of the main terminal window.  When
using a Status Window, this option controls whether or not the Status Area can be
covered up by other windows.

ENTERWINDOWROUTE=TRUE/FALSE  This option controls whether the “Route host output
to Window n” function is enabled.

PFKEYLISTMDI=TRUE/FALSE  When set to TRUE, this option causes the PF keys dialog box
behave as a “Child” window inside WinIATE’s “Parent” window.

SOM_AFTER_RESET=TRUE/FALSE  This option controls whether a SOM is placed on the
screen after the Reset key is pushed.  It is not used with SABRE hosts.

SPLASH_FILE=name  This option allows the user to specify the name of the Splash File to be
displayed when the terminal starts up.  The file may be on a local disk drive or on any
disk drive accessible over the network.  The file must be a BMP-type file.  If a
different file is used than the standard InnoSys Splash File, it should incorporate the
InnoSys copyright notice.  If the file cannot be found,  the terminal continues on as if
no Splash File was specified.

SPLASH_TIME=number  This option specifies the number of seconds the Splash File will be
displayed.

TERMKEYS_FILE=name  This option allows the user to specify the name of the Termkeys File
to be used by the terminal.  The file may be on a local disk drive or on any disk drive
accessible over the network.  (If this parameter is not specified, the terminal looks for a
file called “termkeys” in the local directory.)  If no termkeys file can be found,  the
terminal displays an error message and quits.
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Appendix G — Gateway <--> Workstation
Connectivity Problems 

If a Windows workstation won’t  connect to the gateway, the following procedure can help isolate
the problem.  For other types of workstations, follow this same procedure but adapt it for the
specifics of the workstation operating system.

1) Reboot the workstation PC and try to link again.

2) If the workstation says that it cannot find the gateway or the host is unreachable, this is
probably because the “hosts” file is not set up properly or the dll has not been properly installed.
Use the following procedure:

i) Try to “ping” the gateway using the tcp/ip address of the gateway PC.  (The ping program
should be on the workstation already).  If this is not successful, do not proceed until the
gateway can be successfully pinged this way.  This kind of a problem is most likely caused by:

a) the installation of the tcp/ip protocol stack on the workstation machine is not correct/
complete, or
b) there is not a network connection between the workstation and the gateway, or
c) the address being used for the gateway is not correct, or
d) there is a duplicate tcp/ip address on the network.

To “ping” the gateway using its tcp/ip address, enter a command such as:

ping 206.21.97.14

ii)  If the gateway can be “pinged” using the tcp/ip address of the gateway PC, try to “ping” the
gateway using the “host name” of the gateway PC.  If this is not successful, the error is probably
that:

a) the host name in the “hosts” file (or DNS) does not have the correct tcp/ip address for
the gateway, or
b) the “hosts” file is in the wrong directory, or
c) the “hosts” file has an incorrect name (the most common error of this type is that the
“hosts” file has an extension such as “sam”.  Use DOS, not Windows, to check the name
of the “hosts” file because the Windows tools often hide the extension name.)  The “hosts”
file should not have an extension.

To “ping” the gateway using its host name, enter a command such as:

ping iate_gw1

The location of the “hosts” file varies according to which tcp/ip protocol stack is being used on
the workstation.  If the standard Microsoft tcp/ip protocol stack is being used under Windows 3.1,
Windows for Workgroups, or Windows 95, the “hosts” file should be in the \WINDOWS
directory.  If the standard Microsoft tcp/ip protocol stack is being used under Windows NT, the
“hosts” file should be in the \WINNT40\SYSTEM32\DRIVERS\ETC directory.

If a non-standard tcp/ip protocol stack is being used, the proper directory varies.  For  example,
the “hosts” file is usually in the \NFS directory when using the PC/NFS tcp/ip protocol stack.  The
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“hosts” file is usually in the \TRUMPET directory when using the Trumpet Winsock tcp/ip
protocol stack.

The “hosts” file is simply a list of names that can be used instead of actual tcp/ip addresses.  For
example, if the gateway machine’s tcp/ip address is 207.21.97.14 and the name assigned to this
address is “iate_gw1”, the “hosts” file should contain a line that looks like this:

207.21.97.14    iate_gw1

iii) If the gateway can be “pinged” using the “host name” of the gateway PC, check that the
service name configured in the terminal is properly entered in the “services” file (also check the
spelling of the service name in the terminal configuration window and in the services file).  If this
is OK, verify that the “iatedll.dll” file is properly installed.   If running Windows 3.1, Windows
for Workgroups, or Windows 95, “iatedll.dll” should be in the \WINDOWS directory.  If running
Windows NT, “iatedll.dll” should be in the \WINNT40 directory.  If “iatedll.dll” is not in the
correct directory, move it to the correct directory and then reboot before trying to link to the
gateway again.

iv) If the “iatedll.dll” file is properly installed, then the most likely reason that the gateway cannot
be found is that the “host name” is not properly entered in the “Configure Link” selection in the
File menu.  Check and recheck this entry with the indicated entry in the “hosts” file.  Another
thing to try is entering the actual tcp/ip address of the gateway PC into the “host name” field
instead of entering the name from the “hosts” file.  One last thing to try is to search for all files
named “hosts”.  If there is more than one file named “hosts”, it is likely that the wrong hosts file is
being used.

3) If the terminal gives the message “socket-level connect failed”, this usually means that the port
number entry that the gateway is using is not properly set up in the “services” file on the
workstation PC.  The standard Service Name used for IATE gateways is “ialcserver”.  The
standard Port Number used for IATE gateways is 1413.  The “services” file is usually located in
the same directory as the “hosts” file.  Check that this file has a proper entry for the IATE
gateway being used.  If the standard names are being used, there should be a line in the “services”
file that looks like this:

ialcserver 1413/tcp

Verify that the service name is spelled properly and that “tcp” is not mistyped.

If there are routers, bridges, and/or firewalls on the network between the gateway and the
workstation, verify that network traffic on the tcp/ip port number which the gateway is using can
be passed through the routers/bridges/firewalls.  
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Appendix H — Frequently Asked Questions
about Encoding 

Q:  What is the “Encoding Feature”?
A:  This feature scrambles messages sent over TCP/IP between the InnoSys IATE gateway and

the IATE client API.  This scrambling is intended only to discourage casual snooping of
those messages on the network.

Q:  Which versions have this feature?
A:  Windows NT gateway:

Gateway (iate_server) 2.2b.4 and above
     Windows workstations:

api (iatedll.dll) 2.4b.1 and above
api (iate32.dll) 2.4b.1 and above

     Unix:
gateway (iate_server) 2.3b.1 and above
api (iatelib.a) 2.4b.1 and above

     Mac: 
IATEtcp: 3.4.4b7 and above
initAPI: 3.4.4b31 and above

Q:  How is this different from “encryption”?
A:  “Encoding” isn’t “encryption”.  “Encryption” is intended for applications that require a higher

level of security than that provided by this “encoding” feature.  InnoSys makes absolutely
no representations or warranties about how easy or hard it might be to ‘crack’ this
encoding scheme.  We believe it provides reasonable protection against casual snooping,
but anyone who is determined to break it will be able to do so.

Q:  How does it work?
A:  The encoding algorithm is secret.  Whatever shielding it provides relies on its being secret.

The scrambling is context sensitive. There is a dependency on the data in the message. The
nth character isn’t always scrambled in the same way.

Q:  How does one turn this feature on and off?
A:  It is necessary to explicitly turn it on in the Unix and NT gateways.  It is automatically turned

on by the Mac IATEtcp gateway.  When it is turned on, it is automatically used with any
client that connects to that gateway and that supports encoding.

Q:  What about compatibility?  Do I have to make sure both ends of the client/server connection
have the ability to do this?

A:  Backward and forward compatibility is preserved - the client and server negotiate to make
sure both support encoding and it is only attempted if both sides can support it.

Q:  What if I already have some other type of security scheme in use in my network?
A:  No problem.  It will all just work.

Q:  Will this encoding effect the performance of my system?
A:  No, encoding has no performance impact.
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Q:  What does InnoSys advise for customers who want stronger security than this ‘encoding’
feature provides?

A:  InnoSys recommends that customers who require TCP/IP security beyond the minimal level
provided by this “encoding” scheme use some other network security methodology, such
as secure routers, etc.  InnoSys does not represent itself as an expert in such network
security issues and encourages those customers who have such concerns to contact the
appropriate network security consultants or other professionals.
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